Lesson 4:

This lesson demonstrates how current points in target curves can be excluded in a fitting project. This option
becomes important if the current measured in a certain region is known to be affected by instrumental artefacts
which cannot be reproduced on the basis of the simulation model. In the present lesson such a situation is
modelled for a chrono-amperometric experiment where the theoretical current may become much higher as the
limiting current that can be measured with the instrument. Note that the maximal current that can be measured in
the optimal current range (i.e. the current range required to achieve a reasonable resolution for diffusion
controlled decay of the long-time current) is usually restricted to a few milli-amperes while the current
theoretically expected immediately after the potential jump tends towards infinity for a sufficiently fast charge-
transfer process. (In a real experiment, the artefact resulting from such an instrumental limitation is even
amplified by IR-drop and/or double layer effects which will be disregarded in the present lesson).

In the first part of this lesson a few theoretical current curves are simulated for a simple but relatively fast
charge-transfer process under chrono-amperometirc conditions. It will be shown then that the correct parameter
values are retrieved if the theoretical curves play the role of target curves in a fitting project. In the second part
of this lesson the theoretical curves are modified such as to model “ideal” experiments measured with an
instrument providing a maximum current of 5mA in the underlying current range. That means, the experimental
current curve is assumed to be totally free of errors with the only exception that any current value larger than
5mA is truncated to this limit. It will be demonstrated then that large parameter errors will be obtained when
using these current curves in the fitting project. However, it will shown at the end of these lesson, that reasonable
results are obtained again if current points mimicking the instrumental limiting current are excluded from the
fitting process.

It is assumed in the following that the reader has already worked through the previous lessons and is familiar
with the procedures and operations described there in greater detail.



I.  Preparation of target curves
For the purposes of the present lesson it is most educational to use theoretical (simulated) chrono-amperometric
current curves as target curves for the fitting project.

1. Start DigiElch, click on New and create a new CA-Simulation Document
2. Click on Simulation -> Edit Properties ( w), make sure that the Chemical Reactions page is activated,

enter the reaction equation for a simple charge-transfer mechanism using the default names “Ox” and “Red”
and complete the input in the following way:

) Charge-Transfer Reaction E° (V) “ al” LieV) ks (cm/s)
1 O +& = Red 0 05 1 A|
:t_]] Species D {cm?/s) Canal (molA)  Ginit (molA)
1 Che 1E-005 0.001 0.001 it
2 Red 1E-005 0 0

m

3. Goto Simulation Parameters, modify Scan and Geometry in the following way

Scan [¥ use same time (s} in all scan segmerts Geometry

Segmert | Estart (/) | Eend (V) | time (s} | -
1 03 1] 0.001 El Time stepsfsegment 500 Plarar :|v
2 1] 03 0.001
3 Area (cm? ,I}'Ii

Simulation Name:
and enter “Data-0” as Simulation Name [Data-0

4. Close the CA-Properties dialog and click on Simulation -> Run -> Fixed Grid Simulation (ial ).
). Then go to

5. If the simulation has completed, click on Simulation -> Duplicate (&

Simulation Parameters, enter 0.01 as Eend (V) for scan segment 1 (resulting in an overvoltage of +10 mV for
the first potential step) and enter “Data+10mV” as “Simulation Name”.

Scan [v use same time (s) in all scan segments
Simulation Name
Segment | Estart (V) | Eend (V) | time () | -
1 03 0.01 0.001 E| Time stepsfsegment 500 Data+10mY
2 (LX) 0.3 0.001

6. Repeat step 4. and 5. using an overvoltage of +20 mV, -10 mV and -20 mV. Assign the names
“Data+20mV”, “Data-10mV” and “Data-20mV” to these simulations. In this way a simulation document
containing 5 chrono-amperometric simulations referring to overvoltages of +20 mV, +10 mV, 0 mV, -10 mV
and -20 mV has been generated. The screen display associated with these simulations is sown in the
following picture:

For the convenience of the user, this simulation document is stored in the “OriginalData.cas”-file contained
in the Lesson4.zip archive. The user may simply open this document instead of executing steps 1 to 6.
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Il.  Running a fitting project using the simulated curves as target curves
We will show now that the exact charge-transfer parameters, E°(V), ks (cm/s), and the exact diffusion
coefficient, D (cm2/s), will be retrieved by the fitting procedure when using the above current curves in a fitting
project based on a simple charge-transfer mechanism.

1. Click on Document -> Add Simulations to RAM-Disk ( + ). Bypass the appearing dialog box by clicking
on OK. Then you may close the simulation document.

2. Create a new CA-Simulation Document, click on Data Fitting->Prepare Fitting Project, enter the reaction
equation for a simple charge transfer mechanism and starting parameters which are distinctly different from
those used in the target curves and select E°(V), ks (cm/s) and D (cm?/s) for being optimized by the fitting
procedure (see step 10. in Lesson2 for more details):

:t_.ll] Charge-Transfer Reaction E" (V) ol L{eV) ks(cms)
1 O + e = Red 0.05 0.5 0.1 it
-
:t_)] Species D (cm?/=) Canal (molA) Ginit (mol A1)
1 O 2E-005 0.1 0.1 it
2 Red 2E-005 0 0

Also do not forget to link the diffusion coefficients of Ox and Red (see step 11 in Lesson2 for more details).

Before closing CA-Properties with OK go to Preferences and modify the default settings as follows

Fitting Controlling Data Fitting

~ . .

uze open circles for simulated curve Max. number of fterations lzni
~ . . .

uze filled circles for simulated curve Exit f 4515 smallerthan [0.001
" uze open circles for exp. cure

) ) IV apply cument nomalization

" uze filed circles for exp. curve

[ save optimized parameterfile

)

uze salid lines for both
[ use adaptive grid simulator



3. Click on Data Fitting->Select Data Target Curves form RAM-Disk ( & ), select the five files and click on
OK

RAM -Disk files:

Add to List I

Data-20my_Ra_1

List of selected files:

Data+10mv_RAM_4
Drata+20m_Rih_5

o]

Cancel | Remove fram List |

4. Click on Data Fitting->Run Fitting Procedure ( and watch how the program is trying to find the “best
fit”. After having completed the 30 iterations, the agreement between simulated and target curves is perfect
and the eéact parameter values are retrieved by the fitting procedure within a numeric rounding error of
about 107 :

Optimized Parameters Optimized Parameters

Optimized Parameters

Eo (Ox +e =Red) -

ks (Ox + e =Red

- -

Optimized value I -4.9373E-013

Upper limit |2-0996E—013
Lower limit I-l- 1974E-012
Confidence level I 'I

Optimized value I 1
Upper limit I 1
Lower limit I 1

Optimized value I 1E-005

Upper limit I 1E-005

Lower limit I 1E-005
Confidence level m

Confidence level IQQ.?% vl

This is not surprising because the target curves are simulated ones obtained with these parameter values.

I11.  Running a fitting project using target curves in which an instrumental artefact is

mimicked

Now we are going to modify the target curves such as to mimic an instrumental artefact. It is assumed for this
purpose that the current curves simulated above are used for mimicking ideal experimental curves measured with
an instrument that is built up from operational amplifiers working with a +15V power supply. It is also assumed
that the experiments were measured in a current range working with a 3kQ resistance in the feedback loop of the
current follower so that a maximum absolute current of 5mA can be provided by the instrument. That means any
absolute current value larger than 5mA is truncated to this value while the rest of the current curve is assumed to
be totally free of errors for the sake of simplicity. The current curves modified in this way are included in the
“ModifiedData.cas”-file contained in the Lesson4.zip archive. They are shown in the following picture:

These files can be prepared by exporting (in use-format) the simulations produced as described above in step 1 to
6. (For convenience, the data are saved in “OriginalData.cas”-file contained in the Lesson4.zip archive). Open
each use-file with an ASClI-editor and replace any current value larger than +5mA with +5mA and any current
value smaller than -5mA with -5mA.
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Theoretically the most reliable information about the nature of the charge transfer process is just contained
in the current values following immediately after the potential jump. It should be clear for this reason that it
makes no sense to use “experimental” curves as target curves in a fitting project if these current points are
known to be falsified (either artificially as for the purposes of the present lesson or) by real instrumental
artefacts resulting indeed from a not sufficiently high current supply or from a not ideal compensation of IR-
drop and coupled double layer charging effects. (Note that a short time current of several amperes may be
required for re-charging the double layer of a macro-electrode on a microsecond time-scale.) This will be

demonstrated now by using the current curves shown above as target curves in a fitting project.

5. Open the “ModifiedData.cas”-file. Click on Document -> Add Simulations to RAM-Disk ( + ) and enter
“Modified” in the appearing dialog box to make it easier to
distinguish the modified files from the original ones. Then close
the “ModifiedData.cas”-document in order to return to the Fitting

Add/Copy Simulations to RAM-Disk &J

Add the following identifier to all simulation names

| Modified

6. Click on Data Fitting->Select Data Target Curves form RAM-Disk ( E) and remove the original target

Menu.

curves from List of selected files. Then add the modified ones and close the dialog box with OK.

]

RAM -Disk files:

Data-20my_RAM_1

Modified_Data-0_Rab_10

Add to List
List of selected files:

oK Canecel Remave from List

o)

RAM -Disk files:

List of selected files:

Datar20mY_AAH_]
M2

Add to List

o]

Cancel

Modified_D ata+20m'_RAM_B
Modifisd_Data+10my_RAM_7

Modified_Data-0_RAM_T0

FRemove from List




7. Click on Data Fitting->Run Fitting Procedure (E). Obviously, the fitting procedure does not stay with the
exact parameter values (used as starting values). After a few iterations the fitting procedure finds the
minimum standard deviation with the following parameter combination:

Optimized Parameters Optimized Parameters Optimized Parameters
Eo (Ox + & = Red “ Eo (Ox +& =Red) -
ks (Ox + e =Red) . ks (Ox +e =Red

D {Ox)

Optimized value |0.003853 Optimized value ’W Optimized value |8.4053E-006
Upper limit IW Upper limit W Upper imit | 8.4685E-008
Lower limit [0.0036435 Lower lmit [0.85161 el

Confidence level |68.3% > Confidence level |68.3% A Confidence level |58.3% d

On the first glance, the agreement between target curves and simulated ones seems to be pretty good but looking
at the optimized parameter values reveals that the error in the heterogeneous rate constant and in the diffusion
coefficient amounts to about 15% and the standard potential has been shifted away from the correct value by
about 4 mV. Note that 5000 current points are included in the five target curves and only 8 individual current
points have been modified in three files! The example demonstrates the big effect that must be expected for the
chrono-amperometric determination of (fast) heterogeneous rate constants if only a few current points in the
short time current following immediately after a potential jump are affected by instrumental artefacts.

IV. Running a fitting project where individual current points in the target curves are
excluded from being fitted
It will be demonstrated now how “wrong” current points can be excluded from the fitting project. This is easily
done in the present example because we do exactly know that any current point representing the limiting current
(with an absolute value of 5mA) is likely to be artificially truncated to this value. For this reason we are going
now to mark all current points amounting to £5mA such that they will be excluded from data fitting. This is done
as follows:

1. Click on Data Fitting -> Exclude Current Points from Fitting ('E) to enter the Exclude Menu. The window
associated with menu shows the target curve which was the active one displayed when leaving the Fitting
Menu. The target curves “Data+10mV” and “Data+20mV” do not contain “wrong” current points. Thus

click on View -> Activate -> Next Curve ( b ) or View -> Activate -> Previous Curve ( q ) to activate

@,

one of the remaining curves. The use the View -> Zoom (° =) command for a better inspection of the
current points by drawing a rectangle around the region containing the current points which are to be
excluded from the fitting project as shown in the left picture for the target curve “Data-20mV”. After
releasing the mouse button, the zoomed display shown in the right picture is obtained

i Modified_Data+20mV_RAW.6 - Modified Dats-20mV_RAM.8 =S ¥ Modified_Data+20mV_RAL6 - Modified_Dats-20mV_RAM_3 = ||
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Then click on Exclude Data -> Define Region ( R ), press down the left mouse button and (similarly as
with the zoom command) draw a rectangle around the current points which are to be excluded from the
fitting project as shown below in the picture on the left hand side. After releasing the left mouse button, the
current points marked to be excluded from the fitting project will be drawn in red (unless the excluded
region contains less than two current points) as shown in the picture on the right-hand side:

W3 Modified_Data+20mV_RAM 6 - Modified_Data-20mV_RAM 8 === P2 Modified_Data+20mV_RAM 6 - Modified_Data-20mV_RAM & (=& ==
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Click View -> Unzoom (© %) to return to the original screen display. Then proceed analogously to exclude
the “wrong” current points following immediately after the potential jump at 0.001 s.

After having completed the target file “Data-20mV” use the View -> Activate -> Next Curve ( b ) -
command to activate the next target curve containing “wrong” current points which need to be excluded.

L3
Click on Exclude Data -> Close (D) to return to the Fitting Menu if all target curves have been
completed.

Redo data fitting. Click on Data Fitting->Run Fitting Procedure (
regained after a few iterations:

). The following parameters will be

Optimized Parameters Optimized Parameters Optimized Parameters

- Eo (Ox +& =Fed b Eo (Ox +e =Red) -
ks (Ox +e =Red

ks (Ox +e = Rec;)
D {Ox)

- - b

Optimized value |-1.6943E—010 Optimized value Il— Optimized value IW
Upper imit [ 5.7726E-011 Upperimt [T Upper lmit [1£005
Lower limit |-2-3114E-010 Lower limit Il Lower limit IlE—UUE

Confidence level - Confidence level Igg.?‘}‘u vI Confidence level IQQ.?% vI

They are virtually identical with those regained using the original (unmodified simulated) target curves.
Only the error level (visible only for the retrieved standard potential) seems to be insignificantly larger.

Note that the (correct) parameter values shown above will be retrieved by the fitting procedure only if really
all “wrong” current points have been excluded from the fitting project. If you retrieved distinctly different
parameter values, please, inspect the target curves contained in the “ModifiedData.rmd”-file of the
Lesson4.zip archive. For this purpose, clear the actual content of the RAM-Disk (Document -> Clear RAM-

Disk ( x)) and load “ModifiedData.rmd” by means of the Document -> Load RAM-Disk command. Then
select the target curves as described in step I11.6. and inspect the excluded current points after activating the

Exclude Menu by clicking on Data Fitting -> Exclude Current Points from Fitting (%). After returning to



the Fitting Menu and redoing the data fitting with these target curves you should yield similar results as
reported above.

The effect of the operations described above becomes visible by comparing the simulated current curves
with the “experimental” ones as shown below for the (zoomed) display of the current points following
immediately to both potential jumps
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The green curves represent the “Data-20mV”- target curve including the falsified current points plotted in
red while the black lines are the simulated current curves. Obviously, there is a perfect agreement between
target curves and simulated ones except for the £5mA-current points mimicking the limiting current of the
instrument. The latter are marked to be excluded from data fitting and their effect on the standard deviation
between simulated and target curves is therefore ignored.



